kæmpe problem med Arduino Uno til laser ingraver (Læst 1194x)

Offline plovmann

  • Nyfødt El-Elsker
  • *
  • Indlæg: 1
  • Antal brugbare Indlæg: 0
    • Vis profil
kæmpe problem med Arduino Uno til laser ingraver
« Dato: Juli 08, 2022, 09:50:22 »
Hejsa.  Har et kæmpeproblem som jeg simpelthen ikke kan gennemskue :(   forsøger at forklare.
Det er en hjemmelavet cnc maskine, hvor jeg har 3d printet beslag så jeg kan skifte mellem spindel og laser. så der sidder 4 Nema 17 steppemotore . Det kører perfekt, og der er ingen problemer

Arduino uno ( GRBL ) med cnc shield.  12 V PSU 15 amp.  laser modul på 10 w. output.
laser er opgivet til  at skulle bruge 4-5 amp  , og jeg har ca. 1 - 1.25 m. ledning imellem arduino og laser.   Det er 1.5 mm2 ledning.  selve PWM signalet og grd. er taget fra Z+ ben på cnc shield.

problemet er at power dykker ved laser ved 100 % power.

jeg måler 12. 25 V. ved arduino og også ved laser når bare det står tændt.  Når laseren så kører 100 % power måler jeg kun 10.72 V ved laser, og det gør jo at den slet ikke er så effektiv som den skal være.

Jeg syntes alt er afprøvet, men selvfølgelig ikke alt siden fejlen stadig er der :)

Det jeg selv tænker er de tynde pins på cnc shield har jo meget tynde ledninger, der har jeg et par cm.  hvor den 1.5 mm2 er loddet på. til sidst går der også en 5-10 cm tynd ledning til stikket på laseren.  både på cnc shield og på laseren finder jeg det umuligt at undgå de tynde ledninger, men ved heller ikke om det kan være grunden. 

Jeg har ( som forsøg og udelukkelse )  udskiftet Uno, cnc shield, PSU fra en stationær pc. før brugte jeg en alm. 10 amp. psu man bruger til 3d printere osv.  ledninger og en sprit ny laser.   Hvad dælen kan der være skyld i det ?
Har tjekket grbl settings flere gange, men der er jo egentlig ikke det vilde. Der er enable / disable laser og $$30  som vel er styrkesettings.  nogle bruger 1000 andre bruger 255, men blot det er det samme i ens program, burde det være ok, og det er det samme.

Det aller aller mest mystiske er at det HAR virket.. da jeg lige fik lasermodulet, skar den igennem 4 mm birkefiner med et pass,  men efter 3-5 gange kun så ikke skære igennem. Da jeg syntes jeg havde afprøvet ALT, måtte det være lasermodulet, som jeg fik ombyttet, men så stadig ikke virker.

Frustrationerne lyser nok ud af mig :) og ja.. det gør de så også :)    Jeg har forsøgt at skrive så mange info som muligt, men mangler der noget så spørg endelig

Skulle nogen ha fiduser, råd eller løsningen hører jeg rigtig gerne om det :) 

Mvh. Lars Plovmann


 

Offline Jesper_Munkholm

  • µProcessoren
  • *
  • Indlæg: 380
  • Antal brugbare Indlæg: 36
  • Alt er Volt
    • Vis profil
Sv: kæmpe problem med Arduino Uno til laser ingraver
« Svar #1 Dato: Juli 09, 2022, 07:29:06 »
Hej
Har du evt mulighed for at lave en test, hvor du lodder et sæt 1,5mm2 ledning parallelt på det der er monteret pt? Det vil udelukke spændingsfaldet! Måske er der knækket nogle kordeller i ledningerne du har på nu!?
Det er mit bedste bud (altså hvis du måler 12v i udgangen og 10v på laseren)
"Buy a man a beer and he wastes an hour. Teach a man to brew and he wastes a lifetime." :)

 

Offline Jesper_Munkholm

  • µProcessoren
  • *
  • Indlæg: 380
  • Antal brugbare Indlæg: 36
  • Alt er Volt
    • Vis profil
Sv: kæmpe problem med Arduino Uno til laser ingraver
« Svar #2 Dato: Juli 23, 2022, 23:26:02 »
Har du løst dit problem? ;)
"Buy a man a beer and he wastes an hour. Teach a man to brew and he wastes a lifetime." :)