Fejlsøgning på marshall højtaler (Læst 858x)

Offline RadioGJ

  • Nyfødt El-Elsker
  • *
  • Indlæg: 3
  • Antal brugbare Indlæg: 0
    • Vis profil
Fejlsøgning på marshall højtaler
« Dato: Oktober 14, 2019, 18:21:12 »
Hej jeg døjer lidt med at finde hvad årsagen til er at min Marshall højtaler ikke virker længere. Den er dog 5 år gammel og har stået i direkte sollys i noget tid. Jeg har skilt alt elektronikken fra kassen. da det gør det nemmere at fejlsøge på. jeg har målt spændingen igennem on/off switchen og det ser fint. Der er dog ikke lys i dioderne og jeg måler heller ingen spændingens forskel når jeg kører op og ned på de 3 modstande som ændre på volumen,bass og trebel. Så for mig virker det til at være et problem i printet op til det. Jeg er dog lidt ny til det så vil gerne hører om nogle måske kunne tænkte hvad årsagen er til at den ikke virker længere om hvor og hvordan der skal måles for finde hvad fejlen er og evt. en udskiftning af en del. Kunne også være nogle vidste at der opstår et bestemt problem med højtaleren efter nogle år.

Mvh. RadioGJ

Link til billeder https://imgur.com/a/5FsDoIX
« Senest Redigeret: Oktober 14, 2019, 21:36:42 af RadioGJ »

 

Offline Icecap

  • U=I*R
  • ***
  • Indlæg: 31
  • Antal brugbare Indlæg: 2
    • Vis profil
Sv: Fejlsøgning på marshall højtaler
« Svar #1 Dato: Oktober 14, 2019, 21:14:27 »
Jeg ser ikke nogle billeder.

Potentiometerne for bas/mid/trebel styr IKKE spændingssignaler med DC. Så det kan du ikke måle på.

Har du tjekket alle sikringer? Det kan meget vel gemme sig en glasrørssikring et sted eller være dårlig kontakt.

Og du har ikke en spænding gennem en kontakt, du har en strøm. Måske petitesser men på et tidspunkt kan det være af stor betydelse at man får det korrekt.

Man har en spænding mellem to punkter og en strøm gennem en ledning.

 

Offline RadioGJ

  • Nyfødt El-Elsker
  • *
  • Indlæg: 3
  • Antal brugbare Indlæg: 0
    • Vis profil
Sv: Fejlsøgning på marshall højtaler
« Svar #2 Dato: Oktober 14, 2019, 21:42:22 »
Hej Icecap mange tak for svar

Jeg målte spænding imellem fase og nul som der går igenmen on/off switchen også på den anden side og det ser fint ud iforhold til spændingen.   

Den eneste sikring som jeg kan se er glasrørsikring der sidder inden vekselretteren og der er forbindelse.

 

Offline Icecap

  • U=I*R
  • ***
  • Indlæg: 31
  • Antal brugbare Indlæg: 2
    • Vis profil
Sv: Fejlsøgning på marshall højtaler
« Svar #3 Dato: Oktober 15, 2019, 03:13:55 »
Du har ikke lys i LED - og hvis ikke den/de er kobblet ind et mærkeligt sted har du ikke DC.

Nu ved jeg ikke hvordan strømforsyningen ser ud, det kan være en primærswitchet sag med tanke på alderen (5 år) eller en transformatorbaseret sag. Men slutresultatet er at der ret sandsynligt ikke er DC til selve forstærkeren.

Brugte en anden browser og kan se billeder nu - og det er definitivt en primærswitchat dims. Dette gør det hele lidt besværligt da 230Vac ensrettes til ca. 325Vdc inden den switches og der kan være ret meget grund til at være meget forsigtigt når man piller i den afdelning.

Den store elektrolytkondensator (længst "nordpå" i første billed) er den kondensator som der bliver ensrettet ca. 325Vdc på.

Er der ikke det er det ensretteren som er død, er der faktisk omkring 325Vdc over den er det ret sandsynligt selve switch-delen som ikke har det godt.

Og det er oftest en normal fly-back switch hvor switch-transistoren er død eller styringen af den transistor er død. Og med de spændningen er det ikke sjovt at pille med det så pokkers meget.

Hvis du har en strømforsyning som kan give i omegnen af 30Vdc kan du teste at kople den på indgangen af printet, dér hvor der normalt lægges 230Vac på. Så måler du spændningen på kondensatorn som skal være i nærheden.

Vend polariteten og mål igen, hvis spændningen er ret tæt på det samme er ensretteren OK og problemet ligger i switchdelen.

 

Offline Jakobsen

  • Lavpas filter
  • ****
  • Indlæg: 250
  • Antal brugbare Indlæg: 39
    • Vis profil
Sv: Fejlsøgning på marshall højtaler
« Svar #4 Dato: Oktober 15, 2019, 17:04:56 »
Lidt search på Marshall 203-JN3018 eller efter Marshall Stanmore fortæller at det er kendt at de går i stykker.

Her er en der bare bruger den til noget andet https://www.youtube.com/watch?v=0EqzEmTbGVQ

Her er der en som bygger en anden forstærker ind i kabinettet og genbruger enhederne
https://techfindings.one/archives/3375

En som heller ikke virker https://www.youtube.com/watch?v=4aJSuT7_y3A
Her står der i kommentarerne:

Dan-Anders Höök
3 years ago
I've been troubleshooting a dead Stanmore today, and it seems like the voltage to the MCU is to low. I get 0.7 volt, the MCU requires something like 3.5 - 5.5. There is a MC34063A used to step down from 15 volts, but I only get 0.7 volts on the output. Can't see any burnt components so I'll try to replace the MC34063. I had to order it so it will probably be in a few weeks. If someone wants to measure this voltage on your Stanmore, please note that the circuit board contains high voltage so make sure you know what you are doing. Don't blame me if you mess up. Also note that any warranty will be void if you take if apart. The voltage can be measured on the 4-pin SIL header located in a cutout in the board named "stanmore shield". The two pins closest to the bluetooth-board is voltage and ground. I guess a working Stanmore would have something like +5 volt, instead of 0.7 volts. I applied 5 volts from an external source to these two pins and the LED:s, buttons and bluetooth works just fine then. I had the Stanmore's power cable disconnected while doing this, i.e only the MCU and bluetooth where powered. I am pretty sure that the power to the amplifier is OK and I didn't want to stretch my luck. I'll let you know what I find :-)


Walter Chaves
2 years ago
Hey Dahook, I managed to test what you describe in first comment, I find out the SIL header you mention on the board name stanmore shield, and it gives me a random measure between 2.4 and 1.5 I don't have nothing to power up the circuit so I did it with the unit connected, I guess the voltage is not as low as your, but I'm collecting information to get it to a person with some more experience than me.
Thanks for your help

Måske du kan lokaliser de regulatorer de snakker om og se om der er input spænding
Her er data på MC34063
https://www.onsemi.com/pub/Collateral/MC34063A-D.PDF


 

Offline RadioGJ

  • Nyfødt El-Elsker
  • *
  • Indlæg: 3
  • Antal brugbare Indlæg: 0
    • Vis profil
Sv: Fejlsøgning på marshall højtaler
« Svar #5 Dato: Oktober 16, 2019, 15:07:06 »
Du har ikke lys i LED - og hvis ikke den/de er kobblet ind et mærkeligt sted har du ikke DC.

Nu ved jeg ikke hvordan strømforsyningen ser ud, det kan være en primærswitchet sag med tanke på alderen (5 år) eller en transformatorbaseret sag. Men slutresultatet er at der ret sandsynligt ikke er DC til selve forstærkeren.

Brugte en anden browser og kan se billeder nu - og det er definitivt en primærswitchat dims. Dette gør det hele lidt besværligt da 230Vac ensrettes til ca. 325Vdc inden den switches og der kan være ret meget grund til at være meget forsigtigt når man piller i den afdelning.

Den store elektrolytkondensator (længst "nordpå" i første billed) er den kondensator som der bliver ensrettet ca. 325Vdc på.

Er der ikke det er det ensretteren som er død, er der faktisk omkring 325Vdc over den er det ret sandsynligt selve switch-delen som ikke har det godt.

Og det er oftest en normal fly-back switch hvor switch-transistoren er død eller styringen af den transistor er død. Og med de spændningen er det ikke sjovt at pille med det så pokkers meget.

Hvis du har en strømforsyning som kan give i omegnen af 30Vdc kan du teste at kople den på indgangen af printet, dér hvor der normalt lægges 230Vac på. Så måler du spændningen på kondensatorn som skal være i nærheden.

Vend polariteten og mål igen, hvis spændningen er ret tæt på det samme er ensretteren OK og problemet ligger i switchdelen.

Igen mange tak for svar.  Jeg har faktisk bygget min egen m14 strømforsyning så jeg vil prøve at gøre som du skriver. Jeg tænkte på hvad er det 'sorte stas' der sikker omkring hvor transformeren. Er det for at beskytte imod kortslutteringer da spændingen kan hoppe?.

 

Offline Icecap

  • U=I*R
  • ***
  • Indlæg: 31
  • Antal brugbare Indlæg: 2
    • Vis profil
Sv: Fejlsøgning på marshall højtaler
« Svar #6 Dato: Oktober 16, 2019, 15:41:32 »
Det sorte er en lim som skal forhindre tunge komponenter i at ryste løs under transport. Sådan er normalt ved høje-og-tunge konponenter men kan have forskellige farver.

De 3 blå skiver-med-ben som sidder parallelt lige "syd" for sikringen er VDR, en spændingsafhængig modstand som fungerer lidt som en zener for AC og høje spændinger.

De 2 gule kondensatorer lige "nord" for sikringen sammen med spolen mellem dem er støjfilter på 230V siden.

Transformatoren med teksten "TRISTAR" på er selve switch-transformatoren.
Transistoren indeklemt i hjørnet "nord-øst" for transformatoren er selve switch-transistoren.
De kredse som findes "øst nord-øst" for transformatoren er styrningen af switchningen.